Synergy

Issue Tracker (powered by SPIT)

Bug #3785 - Synwinxt.dll error opening file for writing during install of 1.4.15

Status:
Fixed
Priority:
Normal
Assignee:
None
Category:
None
Target:
1.4.16
Found:
None
Created by:
Created on:
23 Oct 2013 19:27
Updated by:
None
Updated on:
6 Feb 2014 18:43
Platform:
None
Google ID:
None
Redmine ID:
None

  • Duplicated by: Support #3768 - failed to load shell library, synwinxt.dll is missing or invalid / XP Pro Sp3
  • Duplicated by: Support #3769 - failed to load shell library syswinxt.dll is missing or invalid
  • Duplicated by: Support #3776 - Installation failed
  • Duplicated by: Support #3811 - Upgrade to 1.4.15 on Windows fails due to locked synwinxt.dll
  • Duplicated by: Support #3815 - After installing client on WinXP it wont start

Steps to reproduce:

  1. On both a Windows 8.1 machine and on a Windows 7 machine both 64x start the install of 1.4.15 of 64 bit
  2. During install receive error "Error opening file for writing" for C:\Program Files\Synergy\synwinxt.dll - I believe this happens on the registration of the file, but I'm not 100%%%%%%%% sure.
  3. Presented with the Abort, Retry or Ignore.
  4. Click on Ignore and the program works fine afterwards. (Though both were uninstalling either 1.4.14 or 1.4.12 during install. Have not tested a completely clean install.)

#1

23 Oct 2013 20:00: Joshua Parnell wrote a comment.

I can confirm this is an issue on Windows 7 x64, Windows 8 x64, Windows 8.1 x64 using the 64 bit Synergy client. Have not attempted with 32 bit client or 32 bit computers.


#2

23 Oct 2013 20:32: Tim Norman wrote a comment.

Yes both the 8.1 and 7 machine are x64 with 64 bit client. Forgot to mention that.


#3

23 Oct 2013 20:33: Tim Norman wrote a comment.

Install not client.


23 Oct 2013 20:35: Tim Norman changed Einzelheiten.

Added 180 character(s).


#4

24 Oct 2013 06:02: Ben Wells wrote a comment.

Can confirm this is an issue on Windows 7 x64. Clicked "ignore" and went through install. Synergy is working but drag and drop does not work.


#5

24 Oct 2013 13:26: Owen Keane wrote a comment.

Can confirm that same error with Win7 64bit install - 'error opening file for writing etc.' however Synergy does not work - although starts and says accepts connection - does not in fact work with Mac OSX 10.6 client


#6

29 Oct 2013 13:57: Matt Henry wrote a comment.

Windows 7 64 bit here. Was having this issue and tried the following: I tried to manually delete the synergy folder and it said something?.exe was using the dll. So I killed that process and tried again. Then it said ibnet_client.exe was using the dll. So I killed that; then it said Catalyst Control Center: Host application was using the dll. Uninstalled synergy using uninstaller. Restarted. Installed again - fixed the issue.


#7

31 Oct 2013 02:46: Peter Robertson wrote a comment.

V1.4.15 Server = Win 7 32 bit. Client = Win 7 64 bit. No error messages during install. Everything I've tried so far works except: - Drag and drop of files - Copy/Cut and paste of files - Copy/Paste of text data into an open doc worked once then failed thereafter - Copy/Paste of image data into an open doc failed.

So, I get what I got before, without at least copy/paste it isn't much good to me.

Peter


#8

31 Oct 2013 02:52: Peter Robertson wrote a comment.

By the way, with reference to my feedback above, I understand that getting this type of support across a range of platforms is a really difficult challenge, and chops to Nick & Co for sticking with this. I will definitely continue to test new versions and will leave it installed as soon as these features are working.

Cheers

Peter


#9

6 Nov 2013 08:12: Damon Mota wrote a comment.

based off of Matt's info i used app unlocker and deleted folder.. rebooted and then did install.


#10

7 Nov 2013 15:24: Jason Woodall wrote a comment.

I have this issue on both: - windows 7 64 bit - windows vista 32 bit


#11

7 Nov 2013 18:09: Tim Norman wrote a comment.

I concur with Damon's and Matt's info. I uninstalled the program on both the Win 8.1 64x machine and the Win 7 64x machine. I attempted to remove the folder on the Win7 machine but it required me to shutdown winlogin (which I couldn't), so instead I rebooted and then removed the folder. I then reinstalled and I had no errors during install. On the Win8.1 machine I uninstalled, rebooted, deleted the old folder, and then reinstalled. No errors on that machine either. I now have drag and drop working and copy and paste (at least with text) without issue as well. I do wish there was some sort of visual feedback for the drag and drop. I didn't think it was working for a bit until I noticed the desktop getting some added items. (my desktop tends to be a little cluttered)

So if everyone on the Windows machine follows...

  1. Uninstall older version (or current)
  2. Reboot the machine
  3. Delete the Synergy folder from Program Files and/or Program Files (x86)
  4. Reinstall the latest synergy.

For me no errors and it appears to be working. I'm guess the installer needs to catch that it cannot remove the old program fully and that a restart is required before it can be installed.


8 Nov 2013 23:12: changed Tracker.

Support Bug


8 Nov 2013 23:12: changed Status.

New Accepted


8 Nov 2013 23:12: changed Einzelheiten.

Removed 26 character(s).


8 Nov 2013 23:12: changed Target.

1.4.16


#12

10 Nov 2013 02:48: George Webb wrote a comment.

Win XP 32bit, previously running 1.4.12, trying to upgrade to 1.4.15: same problem (failed to load shell library, synwinxt.dll is missing or invalid; failed to start server: unable to open screen). Tim's 4 steps did not work for me. Nor did I see any errors with the installer. Any other workarounds?


#13

12 Nov 2013 20:42: Keith Esau wrote a comment.

George Webb is correct, this doesn't work. Win XP 32bit still cannot load synwinxt.dll. And using 1.4.12 no longer works either - the protocol is different (I am using 1.4.15 on the other machines for drag-n-drop). I don't use my Win Xp machine much, but when I do, I NEED Synergy. Please fix this ASAP!


#14

14 Nov 2013 05:47: Gerhard Visser wrote a comment.

Same here. Synergy 1.4.15-Windows-x64. Windows 7 SP1.


#15

14 Nov 2013 10:52: Kjetil Skaret wrote a comment.

Same issue here, with Windows XP X86 SP2. Server Running 1.4.15 X64 on Win7. Rolled back to 1.4.12, works again.


#16

17 Nov 2013 21:24: Matthew Gambrell wrote a comment.

I think this is due to the use of RegDeleteTree in synwinxt.cpp This function is unavailable pre-vista. Use SHDeleteKey instead. It should be a super-simple fix (the API appears identical). I'd test and submit a patch if it wouldnt take longer to download 1GB of QT and python deps and then wrestle with them all than it would to actually fix it. To my knowledge, theres no reason SHDeleteKey wont work in this situation.


#17

16 Dec 2013 11:56: Bruce Bird wrote a comment.

Same problem. I was successfully using 1.4.12 with a Win 7, 64bit server and XP, 32 bit client. Donated and upgraded to 1.4.15 to get the drag and drop function and now find that I cant get 1.4.15 working on the client with the error message 'synwinxt.dll is missing or invalid'.

Tried the various fixes listed here without success. Having deleted the 1.4.12 version download from my machine I don't have any Synergy at all. :-( Is there anywhere to download the earlier versions?


#18

20 Dec 2013 11:02: Renaud LE MORTELLEC wrote a comment.

http://synergy-foss.org/download/?alt


#19

29 Dec 2013 11:38: Andrew Lawson wrote a comment.

Having the same problem. Seems like the problem has been around for a bit as well as there have been no nightly builds since Oct31st. Guess Devs are taking a 2 month break?


#20

29 Jan 2014 11:01: Richard Mayes wrote a comment.

If you don't want to restart, you can also do the following steps to get it upgraded:

  1. Open a administrative cmd window.
  2. Press CTRL+SHIFT+ESC
  3. Kill explorer.exe
  4. Switch to the cmd window opened above.
  5. Run "rm C:\Program Files\Synergy\."
  6. In the task manager do File>New Task
  7. type "explorer" and press enter.
  8. Re-run the installer

#21

29 Jan 2014 11:04: Richard Mayes wrote a comment.

Step 5 should be (forgot to use code and cannot edit the above comment):

rm C:\Program Files\Synergy\*.*

Also this is for the 64-bit install or a 32-bit install on a 32-bit windows. If you are using the 32-bit install you will need to change to "Program Files (x86)"


#22

5 Feb 2014 02:20: James Smith wrote a comment.

Donated to get drag and drop,but it does not work on a windows xp machine client and win 7 server. You should put a disclaimer on the 1.4.15 that windows xp does not support drag and drop as it was my only reason for donating :(


#23

5 Feb 2014 15:46: Per Skinkerud wrote a comment.

I see that in the latest nightly build there is a workaround for XP: if (osvi.dwMajorVersion < 6) // skipping shell library load ...

However, it is trivial to make synwinxt.dll run on XP. Simply replacing the calls to RegDeleteTree (unsupported) with SHDeleteKey will do the trick. I did this and it runs just fine on XP.


6 Feb 2014 18:43: changed Status.

Accepted Fixed


#24

9 Feb 2014 21:37: Jim Harris wrote a comment.

I have just started a clean install of 1.4.15 on Windows 8.1, same issue. I see that it is marked fixed with a target version of 1.4.16. I will try that.

Thanks


#25

9 Feb 2014 21:51: Jim Harris wrote a comment.

ERROR: invalid shell library, use a newer synwinxt.dll

I guess I will have to wait for a stable release of 1.4.16. Make no mistake, I am a big Synergy fan. I would just really like to be able to use this to control my Debian system from my 8.1 machine. Thanks for everything.


#26

18 Feb 2014 15:31: Ramy Nahas wrote a comment.

Had the same issue but was able to fix it by doing a clean install. Steps below on windows: 1- uninstall Synergy program 2- restart PC to release synwinxt.dll 3- delete the Synergy c:\program files\synergy directory using normal file explorer (this will not remove the configuration you have for server) 4- install the latest release 1.4.16 and it should work with existing configuration


#27

18 Feb 2014 15:47: Aymeric dMdV wrote a comment.

I confirm an error with 1.4.16 when 1.4.15 was installed on Windows 8.1 64bits:

INFO: starting new process
INFO: Synergy 1.4.16 Server on Microsoft Windows 6.2 x64
ERROR: invalid shell library, use a newer synwinxt.dll
FATAL: failed to start server: unable to open screen
ERROR: failed to launch, error: process immediately stopped
INFO: backing off, wait=10s, failures=26
INFO: watchdog status: error


#28

18 Feb 2014 18:17: Jason Woodall wrote a comment.

I had this error, removed synwinxt.dll. This caused explorer to crash every time I opened a file from explorer (.txtr,.pdf, etc), restart did not fix issue.

I had to uninstall synergy and restart to fix the issue.


#29

18 Feb 2014 18:47: Jason Woodall wrote a comment.

Scratch that, as soon as I turn the server on (on client side) this error occurs again. Explorer crashes all the time. running 1.4.16 beta (64 bit, windows 7)


#30

18 Feb 2014 19:38: Taipoka Koroka wrote a comment.

Just go to services - stop synergy service. (If you want, rename synwinxt.dll for example to synwinxt_.dll) Now just reinstall.


#31

21 Feb 2014 22:12: Bob Kern wrote a comment.

Confirmed the above instructions. Stop Synergy service, uninstall Synergy, goto C:Program Files\Synergy folder and rename synwinxt.dll to synwinxt_old.dll, then re-install Synergy 1.4.16 and everything works fine.


#32

23 Feb 2014 13:54: Harry Jennerway wrote a comment.

Confirmed the fix above. The faulty version of synwinxt.dll is 24Kb, after reinstalling it's 27Kb.


#33

23 Feb 2014 21:12: Matthew Steeples wrote a comment.

I got a similar bug to this when upgrading from 1.4.15 to 1.4.16. The file looks like it was in use so didn't get upgraded. The install worked but Synergy failed to do anything. I had to uninstall, rename the synwinxt.dll file (as it was in use by Windows) and then re-install for it to be fixed. I didn't need to restart Windows.


#34

25 Feb 2014 03:13: Vadim Peretokin wrote a comment.

I had the same issue upgrading to .46. Had to uninstall, restart, then install it.


#35

3 Mar 2014 10:29: David Kernan wrote a comment.

As above - had issues with upgrading from 1.4.15 to 1.4.16.

ERROR: invalid shell library, use a newer synwinxt.dll FATAL: failed to start server: unable to open screen ERROR: failed to launch, error: process immediately stopped

Uninstalling, renaming C:/Program Files/Synergy/synwinxt.dll to C:/Program Files/Synergy/synwinxt_old.dll and reinstalling would force Synergy to reinstall the correct .dll file. It then ran as usual.


#36

5 Mar 2014 14:36: Robert Grignon wrote a comment.

I just had this... wasnt upgrading, just started to error out, I then tried to upgrade and got the dll error... I followed Richard Mayes procedure and it worked great (running the latest build (1.4.16-r1969-Windows)on Windows 8.1 64bit

Open a administrative cmd window. Press CTRL+SHIFT+ESC Kill explorer.exe Switch to the cmd window opened above. Run "rm C:\Program Files\Synergy*.*" In the task manager do File>New Task type "explorer" and press enter. Re-run the installer


#37

11 Mar 2014 10:44: Rino Sunarto wrote a comment.

I just had this too. I tried to upgrade from version 1.4.12 to 1.4.16. The steps mentioned by Richard Mayes works perfectly.

I noticed that before running step number 5: del C:\Program Files\Synergy\*.* that synwinxt.dll is still exist in C:\Program Files\Synergy\ after I tried to first uninstall Synergy using Windows' Add/Remove programs. I suppose the installer/uninstaller couldn't remove the (old) synwinxt.dll. The fact that killing explorer.exe helped to remove the dll may suggest that the dll is still being used by explorer.exe when the installer tried to remove it?


#38

18 Mar 2014 02:23: Steve Perez wrote a comment.

After installing version 1.4.16 on a 10.8.4 osx server and a windows 7 x64 client my mouse drags items very quickly on the client. Too fast so i end up highlighting many more icons in a folder or browser than i intended. This happens every time when hold a left click to select items in a folder and draw the square of intended items i want to select. It ends up snapping the selected area to the extreme space it can get. Another example of this usage would be highlighting specific text for copy on a web page using the mouse. It is impossible to select a specific amount of text using the mouse as it selects way more too quickly compared to my mouse movement. This happens on IE9/Chrome v33/FF v27 and windows explorer. Sorry this is hard to describe but it is a major nuisance. Both installs were done after completely uninstalling the older version and installing clean, as i have seen this resolve other issues in the past. Unfortunately this did not fix the issue this time. I believe this issue is related to what others are seeing and this issue should be reopened and looked at. Contemplating going back an older version.


#39

4 May 2014 01:44: David Kelly wrote a comment.

FIXED = run a reindexing of the index files, accessed through the control panel as a part of user/admin maintenance. OK, so I noticed the error with the synwinhk.dll file in win7 pro 32 bit with uptodate service patches, as of 4th May 2014. The computer was running slow with intermittent errors that were gradually increasing. The rebuild of the indexes has fixed the problem, in that it has not reoccured today, when it occurred. Incidentally I have now switched to encrypted connection, having been using synergy prior to the problem with no encryption, just as an exercise in evaluating the product. Thanks for a great product.